A couple of weeks ago I decided that I would like to try the Windows Vista RC1 release to see whether it is going to be worth my while reformatting my PC again to get it up to date with the latest Windows OS. I currently run Windows Server 2003 and find that it is much nicer, and more stable, than Windows XP and thought that it would be an interesting time to compare the old with the new to see what Microsoft has managed to develop this time.

Microsoft seem to have once more lifted the basic UI from the latest OS X and then applied a paint brush to it is evident. Just go to your My Documents and see how you navigate through it. There are also a new set of icons that are bigger and take up more of your desktop as a result. The Sidebar is another OS X rip off – Apple introduced the widgets idea a couple of years ago and suddenly it has appeared in the latest version of Windows!
The Start Menu has been upgraded and now sports a built in find/run bar at the bottom making it even quicker to load a command prompt or notepad or…. It has however put a button that “looks like” the Shutdown button in the corner but is actually a standby/sleep button instead. In order to shut down your computer you need to click the arrow to the right and then click shut down from there. This is incredibly annoying!

Adding further to this annoyance is that the computer automatically protects your system from anything you try to change. “Windows has detected that you are trying to open the Device Manager. Are you sure?” Of course I’m sure – I just clicked on it!!!! This happens all over the system wherever you see a little shield next to an option Windows will ask you for permission to use it. Well why not just disable it? I did and for about 20 minutes I had a more relaxed time looking around the computer. Then I had to reboot. When Vista started back up again a nice red warning was sitting in my system tray. “You have turned off the features you just disabled. Im going to tell you about it with this annoying balloon popup” There seems to be no “I’ll monitor it myself” option as per Windows XP SP2 Security Centre and this became even more irritating.

The aforementioned reboot had been due to the installation of GriSoft’s free AVG – a really quite useful alternative to McAfee, Norton or Sophos. This however brought about my next grievance. The idea of automatically updating your anti-virus when you log on is a fairly standard practice. Vista is now so paranoid that when AVG is trying to update in the background it stops you from what you were doing to alert you to the fact that “A program is running in the background. Do you want to check what it’s doing?” NO ITS MY ANTI VIRUS LET IT RUN IN PEACE. I can see the use of this however – it can help people to see when malicious programs are running in the background that shouldn’t be there but I didnt feel that i needed it running and I didnt want to face a barrage of “Do you want to do….” as I searched for a way to turn it off.

One of the more positive things that I had noticed about Vista a while ago was that if you setup user accounts for children then you could stop them having access to system functionality (like Device Manager) and as an administrator you would need to enter your password to give them access. I didnt get a chance to test if this was still a feature but I am fairly sure that it is which means that this new OS will become a success with the home users who want to make sure that their precious little children arent looking at the latest erotic website or buying viagra off ths internet.

Vista doesn’t strike me however as an instantaneous replacement for Windows XP in the workplace. XP & Server2003 work well together and I can see that for the larger corporations to shell out on site licenses for Vista to install on all their workstations is a while off because they will need to trial it on a small group first to check for teething problems. After which they will probably keep to the old WinXP because the process of upgrading an entire workplace would be more trouble than it’s worth.

After a week of using it I have decided that IE7 is no improvement on IE except for the addition of tabbed browsing which isn’t as nice as Firefox anyway so no need for that. WMP 11 is nasty and so completly different from WMP10 that it’s hard to understand where half the options have gone to so I wont be using it anyway.

Windows Vista does make a lot of improvements over the WinXP interface but at the end of the day I still like to be in control of my computer and when I give it an instruction it shouldn’t question me about it. Amazon have been listing the different variants on its website for a couple of months now and the Ultimate version which I was testing comes in at £325 which is an insane amount of money to spend for a very small upgrade.

If you really want that Vista look download a visual style that has been made to look the part and use that – it then gives you £325 to spend on something more useful!

Like most decent, respectable, knowledgeable people I don’t use Microsoft Internet Explorer to browse the internet. I much prefer to use Mozilla’s Firefox as it is regularly updated, has nice features and looks a lot nicer. This isn’t the problem, it is the uneducated people out there who still use MSIE “because its already there for them and why should they go and waste space on their precious computer by installing TWO web browsers” who make the job of developing websites harder for the rest of us.

I’m not trying to be picky here but in this day and age of everyone sueing everyone else just because they looked at you in a peculiar way having a website that is compliant with the W3C standards as well as any accessibilty ones you care to throw in seems to be a fairly good thing to have.

This is why the site I am currently maintaining no longer uses images without their ALT tag or has fixed size fonts defined in the pages. It has a single CSS stylesheet with fonts labelled as “medium”, “xx-large”, “smaller” etc and I haven’t gone table-tastic to create a layout that “looks good” because that just doesn’t cut it for text-only browsers or screen readers.
Where images used to be used to display text as a banner this has now been done by formatting the area with CSS and a background image applied.

Now, because I am educated and was taught about Accessibility in websites, I have been testing my site as I go through with the W3C HTML Validator, W3C CSS Validator and Watchfire’s Bobby to make sure that I am making it as usable as possible. I have also been using Firefox to ensure that the pages look as I intended them to and apart from a small few layout problems (the site is still in dev) it looks as I expected.

Foolish me to not think about the millions of people who use MSIE because when Microsoft were developing their browser they decided that they wouldn’t follow the W3C’s standards they would go off and write their own ones that only work with IE and cause pages to look completely different as a result.

This leaves me with a dilema. Do I:

  1. ignore all the visitors to the site who use MSIE and just do some basic JavaScript browser detection and send them to http://www.mozilla.org/products/firefox/ to let them get a decent browser
  2. ignore the fact that IE doesnt display pages correctly and just hope that people can cope with the site not working correctly in IE
  3. forget the web standards and bow to the idiocy of the MSIE supremacy
  4. Spend masses of time trying to iron out the different problems with MSIE & standards to get a site that works well for both browsers
  5. Give up and stop maintaining websites until everyone uses a proper web browser.

Whilst my decision of choice would be for (1) this will most likely cause more problems than it’s worth and I will no longer be developing/maintaining the website. If i did (2) I would get just as much grief as if I did (1). (3) is a non-starter – whilst I will admit to being a fan of Outlook and some other Microsot apps it doesn’t mean I won’t give them up for something better and to have an inaccessible but working site goes against the principles of any good developer. This leaves a choice between (4) and (5) and I think it is going to be a case of (5) winning out simply because I dont have the time to fully maintain the site and its going to take more than 4 hrs per week to make the site work properly.

So If you are thinking of developing web pages you have 2 choices. Either make sure that everyone who ever looks at your site is using a browser that is compliant with W3C or don’t bother because you wont be able to satisfy yourself that it’s working correctly.

After a while of waiting I should hopefully be able to get my new mobile phone tomorrow.

The desire for a new, preferably a 3G, phone has been going since the end of April when my contract came up for renewal. Back then I was faced with the £130 for the N80, £50 for the V3i and £99 for the M600. [ Original post ] Since then I had been waiting for the appropriate phone to come into stock so that I could order it. On the 7th September my M600 arrived. During the 7 day “cooling off” period I found the M3100 was available and on the 15th September I sent it back.

When Orange received the M600 back the M3100 was out of stock and I was placed upon the waiting list for the new phone. At about 4pm this afternoon I received a call from Orange Customer Services to say that the phone was in stock and would be with me tomorrow. All I had to do was spend £50 to get it sent to me. So, as I write this the new phone is in the post and should be here between 9am and 5pm tomorrow.

When it arrives I will write more about it and compare it to the phone it is replacing. Needless to say I am incredibly happy.

Well this works fine

No problems with the install, no broken USB, no audio issues!

It seems that there is just no software available for Windows XP Professional x64 so I guess I will have to send this back to Overclockers and try to exchange it for a copy of 32-bit Windows XP Professional as this just seems like a much better option at the moment. I just hope that the PC will still be able to make full use of the available resources!

What a waste of time that seemed to be

Intel’s brand new motherboard doesnt have RAID, XP Pro x64 doesnt seem to have working USB support, all is going down the pan for what was looking at being a very nice new computer for my neighbour.

The system is fully cased up and looking very nice but I am suffering from the problem of the 64-bit architecture of WinXP being completely incompatible with any of the other pieces of software most “normal” people would want to run on their computer.

Now I am by no means a fan on Symantec or their Norton Products (give me Sophos all the way) but for a “normal” home user it is the best of the standard products available on the market. There is however no support for Norton Internet Security 2006 in 64-bit Windows. Having checked the Symantec Website I found that “Symantec AntiVirus Corporate Edition 10.0 will support Windows XP Professional x64 Edition and Windows Server 2003 x64 Editions, available today“… But I don’t want “Corporate Edition” so I did more digging and found an article entitled Compatibility of Symantec consumer products with Microsoft Windows operating systems which stated that “Windows XP Professional x64 Edition or Windows 2003 Server – There are currently no consumer products that are compatible with Windows XP Professional x64 Edition or Windows 2003 Server.” Bring on GriSoft.

GriSoft is my second favourite AV engine (after Sophos of course) as it has a free version that can be loaded onto most computers and provide decent anti-virus protection for no costs. However after downloading and copy a number of files around the HDD I was told that only the paid version of GriSoftAVG supports x64. Time for the big guns

Sophos would, at least, do the decent thing of installing but I found myself unable to start up the InterCheck Monitor which meant that I had no onaccess scans available. Another worthless installation.

Next I tried to install the Intel chipset drivers off the supplied driver CD. This not only refused to install the audio drivers but also successfully managed to break the USB root hubs for all USB ports on the system. Which in turn meant that I thought the system was hanging on boot as I was getting a NumLock light on the keyboard through the KVM but no mouse activity. I plugged the PS2 keyboard and USB mouse from my brothers PC into the new system and I had working KB but still no mouse.

A quick trip to the Intel site to get their Chipset Identification Utility proved that Intel can’t recognise their own hardware, either that or XP x64 was preventing it from detecting properly, so I searched by mobo part number and found the BIOS update, chipset drivers and other software. Flashing the Bios has helped speed up boot time but not solved the faulty USB problem.

Checking Microsoft’s XP x64 FAQ’s there is no support for 32-bit drivers in the 64-bit OS as this would cause everything to fuck up.

As there was no RAID setup I was able to use the second hard drive to install 32 bit XP Pro onto to see if this would be any better behaved… It’s installing now so will publish results soon

Having re-cased a computer for a neighbour I was shocked to find out that it wouldnt simply re-activate (the only change to the hardware was the motherboard). In order to get through the activation process I had to:

  1. Phone Microsoft
  2. Key in the Activation Number given by the XP Activation Wizard
  3. Be told it was invalid
  4. Get transferred to a “Customer Services Representative”
  5. Read them the activation number
  6. Tell them it was an OEM key from a manufactured PC
  7. Change the product key (from something to the one on the old case)
  8. Generate a new activation key
  9. Read this back to the CSR
  10. Have them enter it incorrectly
  11. Re-read it to them
  12. Confirm they made a mistake
  13. Enter their half of the key
  14. Finsh

Or so I thought! The new problem came when I tried to Windows Update and I was told that somebody was trying to give me a counterfeit key and that I should look for a genuine key.

Only after a few reboots and ignoring their “you are illegal” messages did I successfully get it to WU and repatch itself

Why can MS not just make a system that works first time!